OS X Mountain Lion tips and tricks

General

sudo chflags nohidden ~/Library

Plug-ins

  • Flash installs as normal from adobe.com – use either Safari or Firefox to download
  • Java installs as normal from java.com – note that it is a 64-bit release and will not work with 32-bit software (e.g., Google Chrome)

Build environment

  • Xcode – download via the App Store – remember to install / enable the Command Line Tools (Xcode -> Preferences -> Downloads)
  • X11 – no longer included in OS X – install XQuartz instead

MacPorts

  • Installer available from the MacPorts site
  • Post installation config (definitely required for installing Wine):
echo export PATH=/opt/local/bin:/opt/local/sbin:\$PATH$'\n'export MANPATH=/opt/local/man:\$MANPATH | sudo tee -a /etc/profile
if [ `sysctl -n hw.cpu64bit_capable` -eq 1 ] ; then echo "+universal" | sudo tee -a /opt/local/etc/macports/variants.conf; else echo "not 64bit capable"; fi
sudo xcodebuild -license

Useful ports

sudo port install mtr
sudo port install nmap

Wine

sudo port install wine
sudo launchctl load -w /Library/LaunchDaemons/org.freedesktop.dbus-system.plist
launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist
sudo port install winetricks
winetricks vcrun2005sp1
winetricks ie7
winecfg

Xcode, MacPorts and Wine installation instructions adapted from David Baumgold’s site – has additional information and explanations